martes, 2 de junio de 2020

Configuración OpenVPN en Mikrotik

Introducción


¿Qué es Mikrotik?

Mikrotīkls SIA, conocida internacionalmente como MikroTik, es una compañía letona proveedora de tecnología disruptiva de hardware y software para la creación de redes. Mikrotik RouterOS es un software que funciona como un Sistema Operativo para convertir un PC o una placa Mikrotik RouterBOARD en un router dedicado.

RouterOS es un sistema operativo basado en el núcleo Linux, el cual implementa funcionalidades que los NSP e ISP tienden a implementar, como por ejemplo BGP, IPv6, OSPF o MPLS. RouterOS es un sistema versátil, con un gran soporte por parte de MikroTik, tanto a través de un foro como de su Sitio Wiki, proporcionando una amplia variedad de ejemplos de configuración.

¿Qué es VPN?

Una red privada virtual (RPV) (en inglés, Virtual Private Network, VPN) es una tecnología de red de ordenadores que permite una extensión segura de la red de área local (LAN) sobre una red pública o no controlada como Internet. Permite que el ordenador en la red envíe y reciba datos sobre redes compartidas o públicas como si fuera una red privada, con toda la funcionalidad, seguridad y políticas de gestión de una red privada.1​ Esto se realiza estableciendo una conexión virtual punto a punto mediante el uso de conexiones dedicadas, cifrado o la combinación de ambos métodos.

En las líneas más abajo se encuentran los comandos y el fichero .OVPN que he se han usado en el vídeo tutorial.

Sin más preámbulos, arrancamos.

Desarrollo






Creación de Redes (Address)
----------------------------------
WAN 192.168.0.0/24
LAN 192.168.88.0/24
VPN 192.168.10.0/24

Creación de pool VPN
--------------------------
192.168.10.1 - 192.168.10.100

Creación de los Certificados
----------------------------------
Los certificados que vamos a crear a continuación tendrán una validez de 10 años; days-valid=3650

Crear certificado CA
-------------------------
/certificate add name=CA-tpl country="ES" state="ES" locality="Madrid" organization="IT-Bilal" unit="IT" common-name="CA" key-size=4096 days-valid=3650 key-usage=crl-sign,key-cert-sign
/certificate sign CA-tpl ca-crl-host=127.0.0.1 name="CA"

Crear certificado Server
-----------------------------
/certificate add name=SERVER-tpl country="ES" state="ES" locality="Madrid" organization="IT-Bilal" unit="IT" common-name="192.168.88.1" key-size=4096 days-valid=1095 key-usage=digital-signature,key-encipherment,tls-server
/certificate sign SERVER-tpl ca="CA" name="SERVER"

Crear certificado Cliente
------------------------------
/certificate add name=CLIENT-tpl country="ES" state="ES" locality="Madrid" organization="IT-Bilal" unit="IT" common-name="CLIENT" key-size=4096 days-valid=3650 key-usage=tls-client
/certificate add name=CLIENT1 copy-from="CLIENT-tplx" common-name="CLIENT1"
/certificate sign CLIENT1 ca="CA" name="CLIENT1"

Exportar KEY Cliente
--------------------------
/certificate export-certificate CA export-passphrase=""
/certificate export-certificate CLIENT1 export-passphrase=12345678


Exportar KEY con OpenSSL
--------------------------------

"C:\Program Files\OpenVPN\bin\openssl.exe" rsa -in cert_export_CLIENT1.key -out cert_export_CLIENT1.key


Creación del fichero .OVPN
---------------------------------

client
dev tun
proto tcp-client
remote IP #Poner IP pública o nombre DNS
port 1194 #Puerto asignado
nobind
persist-key
persist-tun
tls-client
remote-cert-tls server
ca cert_export_CA.crt
cert cert_export_CLIENT1.crt
key  cert_export_CLIENT1.key
verb 4
mute 10
cipher AES-256-CBC
auth SHA1
auth-user-pass secret
auth-nocache
;redirect-gateway def1


Añadir reglas Firewall desde Terminal
----------------------------------------------

/ip firewall filter add action=accept chain=input comment="Aceptar conexión VPN" dst-port=1194 protocol=tcp 
/ip firewall nat add chain=srcnat action=masquerade src-address=192.168.88.1/24 log=no log-prefix="" comment="Tráfico VPN a LAN"

No hay comentarios:

Publicar un comentario

Comenta...